Keeps Asking Me to Install Flash

Brian Leach's Avatar

Brian Leach

18 Dec, 2018 02:40 PM

Every time I start Goalscape in my browser, I am asked to install Flash. (See attached screenshot) I downloaded and installed the latest Flash.

OS: macOS High Sierra (10.13.6)
Browser: Chrome Version 71.0.3578.98 (Official Build) (64-bit)

Can you tell me how I can get around this issue?

  1. Support Staff 1 Posted by Richard Parslow on 18 Dec, 2018 03:31 PM

    Richard Parslow's Avatar

    Hello Brian

    Good to hear from you again – sorry you have been having trouble.

    This issue is due to the way the latest Chrome works with its Flash Player plugin (rather than using the Flash Player installed on your machine, as other browsers do). Chrome has used a Flash plugin for a while; this button has though only started appearing in the latest updates of the browser. It affects all Flash applications, not just Goalscape Online.

    Even when you are on the latest version of Flash, you will still see that button each time you start a Goalscape Online session.When you click it you should not need to download Flash again; instead you will see a popup with the options to 'Block' or 'Allow' Flash (see the attached screenshot): – when you click Allow, your Goalscape Online workspace will open. Unfortunately there is nothing that we can do to change this behaviour.

    You will be pleased to know that we are moving away from dependence on Flash and the browser. The client software for our Goalscape Mobile app already uses HTML5, Javascript and Google Polymer, along with the latest technologies like Web Components. We are developing this code base into a fully functional webapp; we cannot however indicate a delivery date for this – watch out for announcements.

    In the meantime you can use Mozilla Firefox – since it does not use a Flash plugin, Goalscape Online sessions start up seamlessly (without the 'Get Adobe Flash Player' button).

    Keep achieving great goals!

    Richard

  2. 2 Posted by Brian Leach on 18 Dec, 2018 04:15 PM

    Brian Leach's Avatar

    Thanks, Richard. I like Chrome, so I'll just deal with the button until you switch off of Flash. I really like Goalscape -- it kept me on track all year, and it's nice to see an almost completely shaded wheel this month.

  3. Support Staff 3 Posted by Richard Parslow on 18 Dec, 2018 04:48 PM

    Richard Parslow's Avatar

    Hi Brian

    Splendid. Yes, I like Chrome too, so I am definitely on your side here! We will shortly be making some announcements about our development plans for next year.

    Glad to hear Goalscape is helping you to stay on track with all your goals – watching the progress shading advance across the goal map is indeed very gratifying. Remember always to celebrate your successes too, even the 'little victories' that are steps along the way.

    Enjoy the Holidays!

    Richard

  4. Support Staff 4 Posted by Richard Parslow on 21 Dec, 2018 09:33 AM

    Richard Parslow's Avatar

    Hello Brian

    Quick follow-up: I have just discovered that you can resolve this issue by adjusting the default Flash setting for the Goalscape Online site in Chrome. To do this, click the little 'lock' icon in front of the URL in the address bar to open the Site Settings popup, then change the Flash option from 'Ask' to 'Allow'.

    Cheers!

    Richard

  5. 5 Posted by Brian Leach on 21 Dec, 2018 01:00 PM

    Brian Leach's Avatar

    Thanks, Richard, that appears to have worked.

    -brian

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac