Cannot save without coloring subgoals

Eric's Avatar

Eric

03 Jan, 2010 12:37 PM

Hello. I'm very glad I found your product... it's been fun to use so far and it looks like you are very active in improving it further, which is exciting.

My issue is this:
I have a few goals colored where the subgoals are not. When I save, quit, and open the file again, the subgoals are now colored the same as the parent, but only up to one level.

I have now tested this on a brand new goalscape, with the same results.

I don't know if it's relevant, but just before I noticed the issue, I was trying to export a png on my Mac and got the known issue. I don't know if the coloring issue was present before, as I had not used the coloring feature previously.

Also, I've noticed that it will not re-color goals that have already been colored, and it progressively colors one level at a time each quit and re-open.

Also, during normal operation (no quit and re-open) it will color new siblings the same color as the parent, which I assume is normal. I really wish it didn't do this though.

Thank you,
Eric

  1. Support Staff 1 Posted by Richard Parslow on 03 Jan, 2010 02:34 PM

    Richard Parslow's Avatar

    Hi Eric

    Thanks very much for your post - as I understand it you have identified several issues:
    1. Uncolored goals whose parent and neighbors are colored ACQUIRE COLOR on Save > Close > (re)Open This is a bug that we are fixing for the next update - apologies for any inconvenience.

    2. Will not re-color goals that have already been colored I must admit that I cannot reproduce this on the Mac - when I right-click on a colored (or uncolored, or uncolored but previously-colored) goal I can use the color palette in the normal way to re-color the goal (and its subgoals if selected). Please could you confirm that this happens every time you try to re-color (previously colored) goals.
    If I have misunderstood the issue you are describing here, please give a step-by-step description of the process (ie the relevant selections and mouse-clicks) and outcome(s).

    3. "Auto-coloring" new children (and neighbors) This should depend on whether you have selected the 'Also color subgoals' option when coloring the parent (or more distant ancestor). In our tests here it appears to work correctly.
    As I understand it you would like to replace the current 'Also color subgoals' button with a checkbox (so you can uncheck it and see whether the option is 'on' or 'off'). I can certainly see the sense in this and I confirm that we will investigate this for future updates.

    Once again, many thanks for your post. Although we test thoroughly to ensure the highest possible quality and reliability it is inevitable that some things will slip through the net, so customer feedback really helps.

    Please let me know if there is anything I have misunderstood - and of course feel free to post again if you spot any other apparent anomalies.

    All the best - may you achieve great goals in 2010!

    Richard

  2. Support Staff 2 Posted by Richard Parslow on 06 Feb, 2010 10:57 AM

    Richard Parslow's Avatar

    Hi Eric

    We have implemented new functionality for the 'color goals' feature and have fixed the bugs you describe above, so I am marking this thread 'resolved'.

    Please post again if you hit any more issues.

  3. Richard Parslow closed this discussion on 06 Feb, 2010 10:57 AM.

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac