can't install goalscape on mac Yoesemite

Svecias's Avatar

Svecias

31 Oct, 2014 05:03 PM

Hello.
Just recently I bought a new mac mini and started using Mac OS. Previously I used Windows and was enjoying my perpetual Goalscape license. However, once I try to install goalscape on Mac by double clicking the exec file, it says the following.

"Adobe AIR Application Installer” is damaged and can’t be opened.

I tried reinstalling and downloading Adobe Air numerous times, restarting computer, downloading through different browser but nothing seems to work.

Could you help me please with this problem? Perhaps this is a bug of just released Yosemite operating system?

Thanks

  1. Support Staff 1 Posted by Richard Parslow on 31 Oct, 2014 05:53 PM

    Richard Parslow's Avatar

    Hello Elijas

    Sorry you have been having trouble.

    There is certainly nothing wrong with the Goalscape Desktop installer file, so the install issue you are experiencing is probably due to a problem with your Adobe AIR installation. Instead of simply (re)downloading Adobe AIR, on a Mac you need to run the special Mac Adobe AIR Uninstaller application. So the sequence is:

    1. Uninstall Goalscape Desktop.

    2. Uninstall Adobe AIR – instead of simply moving the AIR icon to Trash, you should use the special 'Adobe AIR Uninstaller' application (usually in Applications > Utilities).

    3. Go to our Download page and follow the steps to install the latest AIR first, then download and run the GoalscapeDesktop.air file. (Note that you may need to enforce the '.air' suffix during the download.)

    If you still have any difficulty please post again and we will give you instructions to reset your Registry for a full 'clean' reinstall.

    We are working on a captive runtime version of Goalscape Desktop that will make the application independent of the local AIR environment – watch out for announcements...

    All the best!

    Richard

  2. 2 Posted by Elijas on 31 Oct, 2014 06:24 PM

    Elijas's Avatar

    Hi Richard and thanks for your response.

    I just installed goalscape and everything works perfectly! In utilities section, I noticed there's an app called "Adobe Air application installer". I double clicked on it and then ran the Goalscape installation file.

    So apparently, it all had to be done manually as opposed to automatically on Windows. Part of that is because I am technically challenged on the new operating system.

    Anyway thanks, it's all solved!

    Regards

  3. Support Staff 3 Posted by Richard Parslow on 31 Oct, 2014 06:53 PM

    Richard Parslow's Avatar

    Hi Elijas

    Great! Glad it is all working OK for you now – thanks for letting us know.

    For future updates the autoupdater process should work fine on your new Mac – as long as the Adobe AIR installation is up to date. And of course when we deliver the captive runtime version the local AIR environment will not be a factor.

    Keep achieving great goals!

    Richard

  4. Richard Parslow closed this discussion on 31 Oct, 2014 06:53 PM.

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac