Can't Exit Goalscape on MBP with Yosemite

Maritn Braun's Avatar

Maritn Braun

20 Nov, 2014 09:34 PM

On a Macbook Pro Retina with Yosemite, Goalscape will load normally, but when I try to close ("Goalscape", "Beenden") nothing happens. Killing the process through the Apple menue works. Adobe Air is latest version.
Thank you very much
MB

  1. Support Staff 1 Posted by Richard Parslow on 20 Nov, 2014 10:59 PM

    Richard Parslow's Avatar

    Hello Martin

    Sorry you have been having trouble. You certainly should be able to Quit Goalscape Desktop using the 'X' button, the application command Goalscape > Quit Goalscape or the hotkey shortcut ⌘Q.

    We have not heard from anyone else having a similar issue and we are not able to reproduce it in our internal tests. The problem may indeed have something to do with a mismatch with the local installation of Adobe AIR, even though you have the latest version installed. So please try the following:

    1. Uninstall Goalscape

    2. Uninstall Adobe AIR completely. To do this, rather than simply dragging its icon to Trash, run the special 'Adobe AIR Uninstaller' application – this is usually in Applications > Utilities.

    3. Go to our Download page and follow the steps to install the latest AIR first (using the 'Adobe AIR Installer' application), then download and run the GoalscapeDesktop.air file. (Note that you may need to enforce the '.air' suffix during the download.)

    Please let us know if this works for you. If it does not work, please confirm whether this is a first-time installation of Goalscape Desktop, or if you have recently upgraded to OS X 10.10 Yosemite on a machine where you already had the application installed.

    Once we are sure we have fixed the Quit issue, we will send you a preview copy of the special High Resolution version of Goalscape Desktop that we have developed for Retina screens.

    All the best

    Richard

  2. Support Staff 2 Posted by Richard Parslow on 26 Jan, 2015 10:01 PM

    Richard Parslow's Avatar

    Hi Martin

    Here is a copy of the latest version of the Goalscape Desktop HighRes application for you to install on your new Retina machine. Download this installer file, save it to your hard drive and run it with a double-click. You have a spare activation in case you need to reactivate it.

    Enjoy the journey!

    Richard

  3. 3 Posted by Martin Braun on 26 Jan, 2015 10:25 PM

    Martin Braun's Avatar

    Thank you very much - this works very well!
    Best regards
    Martin

    -- 
    Martin Braun
    [email blocked]

    Am 26. Januar 2015 bei 23:02:02, Richard Parslow ([email blocked]) schrieb:

  4. Richard Parslow closed this discussion on 26 Jan, 2015 10:26 PM.

  5. Richard Parslow re-opened this discussion on 12 Feb, 2015 12:53 PM

  6. Support Staff 4 Posted by Richard Parslow on 12 Feb, 2015 12:53 PM

    Richard Parslow's Avatar

    Hi Martin

    Here is the latest version of the Goalscape Desktop HighRes application for machines with the Retina display. Download this installer file, save it to your hard drive and run it with a double-click. You have a spare activation in case you need to reactivate it.

    Enjoy the journey!

    Richard

  7. 5 Posted by Martin Braun on 16 Feb, 2015 02:38 PM

    Martin Braun's Avatar

    Hi Richard,
    thank you for the link. Interestingly the old problem is back with this
    latest version. The beta version you had sent beforehand had solved the
    problem...
    Best regards
    Martin

  8. Support Staff 6 Posted by Richard Parslow on 16 Feb, 2015 02:58 PM

    Richard Parslow's Avatar

    Hello Martin

    Sorry you are experiencing this issue – thanks for taking the time to report it.

    We are still unable to reproduce this error in our internal tests; and nobody else has reported it. We will of course do our best to trace and fix it!

    In the meantime, our best guess is that it is something to do with the way Goalscape Desktop is interacting with the local Adobe AIR environment. So please could you try the following:

    1. Uninstall Goalscape Desktop

    2. Uninstall Adobe AIR

    3. Install the latest version of Adobe AIR from here: http://get.adobe.com/air/

    4. Reinstall the latest version of the hi-res Goalscape Desktop software using the installer file posted here.

    Please post again to let us know if that works; if not we will do a detailed investigation.

    All the best

    Richard

  9. Support Staff 7 Posted by Richard Parslow on 16 Feb, 2015 05:13 PM

    Richard Parslow's Avatar

    Hi Martin

    Quick follow-up: if you experience the error after uninstalling and reinstalling both Adobe AIR and Goalscape Desktop (hi-res), please send us the error log. On a Mac this should be in your Library here:

    /Users/[username]/Library/Application Support/com.goalscape.app.GoalscapeDesktop.[guid]/Local Store/logging/error-log.txt

    (where [guid] is a long character string)

    You can do this before or after you Force Quit; but not after starting a new session (the logs are reset on each session start).

    If you cannot see the Library folder under your username please post again and we will give you instructions for accessing it.

    Thanks for your patience and cooperation here.

    Richard

  10. 8 Posted by Emmett Lazich on 17 Feb, 2015 12:03 AM

    Emmett Lazich's Avatar

    Martin, it would be great if you send us a copy of ALL the files in the logging folder. That is not only the error-log.txt file.

    As Richard mentioned the log files are over-written each time Goalscape starts up. So you should send us a copy of the logs after you found you needed to force quit, but BEFORE starting Goalscape again.

  11. Support Staff 9 Posted by Richard Parslow on 18 Feb, 2015 07:19 PM

    Richard Parslow's Avatar

    Hi Martin

    Once you have sent us the log files (in
    Users/[username]/Library/Application Support/com.goalscape.app.GoalscapeDesktop.[guid]/Local Store/logging, where 'guid' is a long character string) please try the following:

    1. Uninstall Goalscape Desktop

    2. Uninstall Adobe AIR

    3. Clear the Registry. You need to delete all the Encrypted Local Data Storage (ELS) files, which are in the following folder:

      Users/[username]/Library/Application Support/com.goalscape.app.GoalscapeDesktop.[guid]/ELS

      You can delete ALL files and folders there that have the form 'com.goalscape.app.GoalscapeDesktop.[guid]'

    4. Install the latest version of Adobe AIR from here: http://get.adobe.com/air/

    5. Reinstall the latest version of the hi-res Goalscape Desktop software using the installer file posted here.

    After you clear the Registry you will need to re-activate your installation – we have of course given you an extra permission to accommodate this.

    This should fix the 'force quit' issue; if it does not, please send us the new log files (which will have been reset on starting the application).

    Thanks for your continuing cooperation here.

    Richard

  12. 10 Posted by Martin Braun on 03 Apr, 2015 07:40 PM

    Martin Braun's Avatar

    Hi Richard,
    I just reinstalled Adobe Air and Goalscape, and it now seems to work. Thank you very much for your help.
    I did not find the registry keys that you had indicated, though - German MacBook Pro Retina with Yosemite. Well, I guess that does not matter any more.
    Best regards
    Martin

    -- 
    Martin Braun
    [email blocked]

    Am 18. Februar 2015 bei 20:19:48, Richard Parslow ([email blocked]) schrieb:

  13. Support Staff 11 Posted by Richard Parslow on 03 Apr, 2015 07:47 PM

    Richard Parslow's Avatar

    Hi Martin

    Splendid! Glad it is all working OK for you now – thanks for letting us know.

    We managed to reproduce the 'cannot quit' issue here so we have our own logs of the event. In case it recurs for you, the fix (Uninstall Goalscape Desktop and AIR, reinstall AIR and Goalscape Desktop) should work in all environments.

    Cheers!

    Richard

  14. Support Staff 12 Posted by Richard Parslow on 03 Jul, 2015 07:49 AM

    Richard Parslow's Avatar

    Hi Martin

    Here is the latest version of the Goalscape Desktop HighRes application for machines with the Retina display. Download this installer file, save it to your hard drive and run it with a double-click. You have a spare activation on your [email blocked] account in case you need to reactivate it.

    Enjoy the journey!

    Richard

  15. 13 Posted by Martin Braun on 05 Jul, 2015 08:12 PM

    Martin Braun's Avatar

    Thank you, Richard.
    This seems to be working just fine.
    Best regards
    Martin

  16. Support Staff 14 Posted by Richard Parslow on 05 Jul, 2015 08:31 PM

    Richard Parslow's Avatar

    Great – thanks for letting us know.

    Richard

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac