GS Launch

Rick Miller's Avatar

Rick Miller

02 Jan, 2015 05:55 PM

Hello all!

      I just recently ran into a problem where the GS application would begin, but remain in the taskbar and would not expand onto the desktop. I found some similar issues in the forum which recommended the delete and reinstall of AIR and GS (as well as the removal of old GS directories in my user/~/AIR folders. I did this and now when I attempt to reinstall I get the attached error message.
     On another attempt, the application installed, launched and sat at the screen (as in Goalscape.png). Although the menus are active, you can't open anything or exit (although you can minimize).
     This is on a Win7 machine (i7, 16Gb, SSD) that otherwise has been running this application fine for almost two years.
 Thanks for your help!

R

  1. Support Staff 1 Posted by Richard Parslow on 02 Jan, 2015 06:47 PM

    Richard Parslow's Avatar

    Hello Rick

    Sorry you are still having trouble.

    As I recall, the fix we proposed last time worked for you when you had a similar issue (with the same behavior and error message). Your message here refers.

    So please could you try it again:

    1. Uninstall Goalscape Desktop using Start > Control Panel > Add and Remove Programs. This will not affect any of your existing goalscapes (.gsp files), stored in your Documents area.

    2. Uninstall Adobe AIR

    3. Go to our Download page and follow the steps to install the latest version of AIR, then download the Goalscape Desktop installer file (you may need to enforce the '.air' suffix when you save this file, since some environments try to change it to '.zip'!).

    4. Double-click the installer file to run it and follow the instructions.

    5. When you reinstall Goalscape Desktop like this you should not need to reactivate the software on that machine. When the application starts you will see all your last-open goalscapes and the Recent list will still be populated.

    If the above does not work, you need to reset your Registry and Preferences. Perform steps 1 and 2 above, then before you reinstall, delete the Encrypted Local Data Storage (ELS) files and the similar SO directories and folders in Preferences. In Windows 7 these are in the following directories:

    • ELS files:

      \AppData\Roaming\Adobe\AIR\ELS<application_id>

      To reset the Registry, remove any folders and files that have the form: user_home - user profile home folder [application_id] - application identifier (in this case: com.goalscape.app.GoalscapeDesktop.[guid])

    • SO files:

      \AppData\Roaming<application_id>\Local Store#SharedObjects

      To reset Preferences, remove the folders that have the form: user_home - user profile home folder [application_id] - application identifier (in this case: com.goalscape.app.GoalscapeDesktop.[guid])

    Note that in some Windows environments these folders may also appear in other areas on your hard drive (especially if you have used Win Updater). So please also look in other areas – eg in similar locations under different user accounts on that machine ('Admin', 'Guest', 'All Users', etc). If you find any files or folders ANYWHERE ON YOUR HARD DRIVE that have the form com.goalscape.app.GoalscapeDesktop.[guid], delete them.

    Then reinstall Adobe AIR and Goalscape Desktop as described in steps 3 and 4 above.

    After you have cleared your Registry, you will need to (re)activate Goalscape Desktop on that machine: I confirm that you have spare permissions available on your account to do this.

    All the best!

    Richard

  2. 2 Posted by Rick Miller on 02 Jan, 2015 11:57 PM

    Rick Miller's Avatar

    Interesting - so check this out. I did as you suggested a couple of times and no dice. The only change that I was doing was specifying where to install - the E:\ drive with the default location. By coincidence, I noticed that it was not installing into that directory, but just dropping some of the files into the root of E (including Goalscape.exe). As a test, I let it install to C:\ and it worked like a charm :)
     

    Rick Miller
    [email blocked]
    Find me at about.me/rickmiller

  3. Support Staff 3 Posted by Richard Parslow on 03 Jan, 2015 09:50 AM

    Richard Parslow's Avatar

    Hi Rick

    That is indeed interesting. Thanks very much for letting us know – that information will be extremely useful if we hear from anyone else having a similar installation issue on Windows 7.

    Keep achieving great goals in 2015!

    Richard

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac