New GS - activation problem

Wojciech Korsak's Avatar

Wojciech Korsak

01 Dec, 2015 10:30 AM

Hi I downloaded new version and have problem with activation.
Please find attachment with screen with details.
I'm working on Windows 10 + newest air

  1. 1 Posted by Wojciech Korsak on 01 Dec, 2015 10:31 AM

    Wojciech Korsak's Avatar
  2. Support Staff 2 Posted by Richard Parslow on 01 Dec, 2015 11:05 AM

    Richard Parslow's Avatar

    Hello Wojciech

    Thanks for taking the time to report this here.

    We have heard of one similar case so we are very keen to identify the cause and find a fix. Most people are able to Activate, so the problem is definitely not with our server (where activations are registered and your account details updated).

    Please could you confirm:

    1. The make and model of your computer running Windows 10

    2. Whether this is a new installation of Goalscape Desktop on that machine, or an update of a previous version – if it is an update please confirm the previous version number (if available),

    Most installation and activation problems are due to an issue with the local AIR environment. I understand that you have the latest AIR, nevertheless please could you try the following:

    1. Quit Goalscape

    2. Uninstall Goalscape

    3. Uninstall Adobe AIR

    4. Go to our Download page and follow the steps to reinstall Adobe AIR first, then download and run the GoalscapeDesktop.air installer file.

    Again, try the Try button, then Quit, Restart and try to Activate.

    Thanks for your patience and cooperation here: with your help we will fix this very quickly!

    Richard

  3. 3 Posted by Wojciech Korsak on 01 Dec, 2015 12:57 PM

    Wojciech Korsak's Avatar

    still nothing.
    Followed all steps.

    My system info as attach

    Wojtek

  4. Support Staff 4 Posted by Richard Parslow on 01 Dec, 2015 01:25 PM

    Richard Parslow's Avatar

    Hi Wojciech

    Sorry you are still having trouble.

    I just noticed that your last successful activation used up the last available permission on your account, so that may have been causing the problem here (although of course you should have seen a more relevant error message).

    I have now given you an extra permission so please try the activation again and let us know if it works for you now. Your answer here will be very helpful!

    Best

    Richard

  5. 5 Posted by Wojciech Korsak on 01 Dec, 2015 01:47 PM

    Wojciech Korsak's Avatar

    still the same error

    Fault code: Server.Error.Request
    Fault string: HTTP request error
    Fault detail: Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032" errorID=2032]. URL: https://www.goalscape.com/gsd-api/activate-license/

  6. 6 Posted by Wojciech Korsak on 01 Dec, 2015 07:12 PM

    Wojciech Korsak's Avatar

    btw,
    I installed new version on 2nd computer.
    During istallation was question - and as I see, working version was:

  7. 7 Posted by Wojciech Korsak on 01 Dec, 2015 07:30 PM

    Wojciech Korsak's Avatar

    on 2nd computer I can't activate also

  8. Support Staff 8 Posted by Richard Parslow on 01 Dec, 2015 07:44 PM

    Richard Parslow's Avatar

    Hi Wojciech

    Thanks for the additional information.

    All your activations are registering here, so again you have reached your limit. Please do not attempt another activation until we post here with news – at that point we will also give you more permissions on your account.

    All the best

    Richard

  9. Support Staff 9 Posted by Richard Parslow on 01 Dec, 2015 08:27 PM

    Richard Parslow's Avatar

    Hi Wojciech

    We are going to reset your password to temp001 to run some tests here. If you are signed out of Goalscape Connect you will still be able to sign in (using that password) while we do our tests.

    Best

    Richard

  10. Support Staff 10 Posted by Richard Parslow on 01 Dec, 2015 09:11 PM

    Richard Parslow's Avatar

    Hi Wojciech

    Some more information, please. It would be really useful if you could send us the logfiles for the Goalscape Desktop session that included a failed Activation attempt. If your latest session was using the Try button, Exit the application and restart, then at the Welcome screen try your username with the password temp001. If that does not work, send us the logfiles before you start another session.

    The logfiles are 3 text files called error-log.txt, goalscape-log.txt and messaging-log.txt.

    There is a slight problem here because Windows environments do not have a definite location for the logfiles, so I am not sure of their exact location on your hard drive. And you cannot use the Explorer Search to find them! So please start looking for the Goalscape Desktop logfiles (under Local Store/Logging) in the following location:

    [user_home]\Application Data[application_id]\Local Store\logging

    Where [application_id] is something like
    com.goalscape.app.GoalscapeDesktop.7AC31F0C6B613204057EF6C630FDA9AC3AF1DB7F.1.

    If they are not there, have a look around some other locations: sometimes the relevant 'com.goalscape.app.GoalscapeDesktop.[guid] directory is under 'AppData/Adobe' or 'AppData/Adobe/AIR'. They may even be under some SharedObjects folder. They may not even be in your user account, but stashed under the 'Admin' or 'Guest User' userIDs!

    Thanks for all your help so far: if you can find and send us the logfiles it will be tremendously useful.

    Best

    Richard

  11. 11 Posted by Emmett Lazich on 01 Dec, 2015 10:40 PM

    Emmett Lazich's Avatar

    Hi Wojciech,

    Please do these steps and tell us the results at steps 5, 6 and 7.

    1. On the same computer where GoalscapeDesktop cannot activate.
    2. Run your web browser.
    3. Open this URL https://www.goalscape.com/gsd-api/activate-license
    4. Confirm that our HTTPS certificate appears valid.
    5. Enter your username and password and try to activate.
    6. Repeat 3,4,5 in a different web browser, on the same computer.
    7. Repeat 3,4,5,6 on a different computer using a different internet connection.

    Thank you.

  12. 12 Posted by Wojciech Korsak on 02 Dec, 2015 02:03 AM

    Wojciech Korsak's Avatar

    Hi Emmett,

    thanx for the info.

    I followed 1-6 with no success.

    As for now - when I click "activate" - the mini clock icon is running and ... nothing happens

    I tried on Chrome browser & Microsoft Edge.

    Wojtek

  13. 13 Posted by Emmett Lazich on 02 Dec, 2015 03:53 AM

    Emmett Lazich's Avatar

    Hi Wojciech,

    In step 3, does the page load without error in each web browsers?

    In step 4, does each browser say our HTTPS certificate is valid? Should be fine, but must be sure.

    In step 5 what is the error? This is the big question/answer!

    Will you get a chance to try 7? eg. try on a laptop using a different Internet connection. Not a solution but it could provide a valid clue. Eg. works if not using your firewall.

    -Emmett

  14. 14 Posted by Wojciech Korsak on 02 Dec, 2015 11:53 AM

    Wojciech Korsak's Avatar

    as for now:
    3) attachment
    4) attachment

    5) now, it's mini clock icon running with no action

    7) I'll try to use phone connection today

  15. 15 Posted by Emmett Lazich on 02 Dec, 2015 11:59 AM

    Emmett Lazich's Avatar

    Hi Wojciech,

    Excellent answers! Thanks.

    OK so now I understand ... the web browser test gives no error at all. That's what I needed to know.

    I failed to explain to you that I never expected the web browser activation (step 5) to activate your instance of Goalscape Desktop. The web browser thing was only to check connectivity.

    So now it is obvious that The Goalscape Desktop app cannot communicate.

    Please try to get those log files which Richard describes above.

    Sorry for the problem! We are using some new mechanism for activating, and obviously it is not yet reliable.

    -Emmett

  16. Support Staff 16 Posted by Richard Parslow on 05 Dec, 2015 10:28 PM

    Richard Parslow's Avatar

    Hi Wojciech

    Please try the attached Preview version of Goalscape Desktop and let us know if you can Activate it on your Windows 10 machine.

    Cheers!

    Richard

  17. 17 Posted by Wojciech Korsak on 05 Dec, 2015 11:22 PM

    Wojciech Korsak's Avatar

    Hi Richard,

    it works :)

    but
    [1] after opening - I saw "error 3001".
    [2] I closed this window
    [3] put login info and
    [4] as I see - activation is ok

    thanx a lot!
    Wojtek

  18. 18 Posted by Emmett Lazich on 06 Dec, 2015 08:07 AM

    Emmett Lazich's Avatar

    Hi Wojciech,

    That's great that we seemed to have made some progress.

    Please tell us more about this Error# 3001? Was that a once-only error? On app open before you activated? Or during some app update stage?

    Thanks
    Emmett

  19. Support Staff 19 Posted by Richard Parslow on 06 Dec, 2015 11:29 AM

    Richard Parslow's Avatar

    Hi Wojciech

    One more question: we understand that you previously had the activation error on 2 machines: a) an update from version 2.7.6 and b) a fresh install.

    Please could you confirm whether you have been able to activate the Preview version on both machines or just one. If it is only working on one machine, let us know which one is still showing the error - and confirm whether it is the same 'abnormal error' message you saw before.

    Best

    Richard

  20. 20 Posted by Wojciech Korsak on 06 Dec, 2015 01:06 PM

    Wojciech Korsak's Avatar

    @Emmett,
    it was once-only error - on 1 computer.

    when I updated GS in 2nd one - there was no window with this error.

    I could not activate on 2nd machine - but I think it is working - just have no more activations left on my account (got this message in GS window).

  21. Support Staff 21 Posted by Richard Parslow on 06 Dec, 2015 01:55 PM

    Richard Parslow's Avatar

    Hi Wojciech

    Sorry about that: the issue was that all your failed activations were registering here! I have given you some extra permissions on your account, so please try activating the software on your second machine.

    Then please post here to confirm whether the activation worked for you on:

    a) an update from version 2.7.6
    or
    b) a fresh install
    or BOTH.

    Thank you very much for your patience and cooperation here – when we have issues it is good to have a friendly, knowledgeable user to help us fix them!

    Richard

  22. 22 Posted by Wojciech Korsak on 06 Dec, 2015 03:20 PM

    Wojciech Korsak's Avatar

    Hi Richard,

    I activated 2nd license on 2nd machine - all works great !
    Thanx a lot for quick actions :)

    I activated both licenses using a) UPDATE version.

    greetings
    Wojtek

  23. Support Staff 23 Posted by Richard Parslow on 06 Dec, 2015 03:24 PM

    Richard Parslow's Avatar

    Splendid! Thanks for letting us know.

    Richard

  24. Richard Parslow closed this discussion on 06 Dec, 2015 03:24 PM.

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac