New on-line App for Windows

lucy's Avatar


28 Aug, 2021 10:07 AM

I have not been able to use Goalscape on my windows laptop since I have been required to download the new on line app. I have tried deleting it and reinstalling many times. I go through all the set up steps but at the end when it launches all I get is the icon and a blank window. Can someone help please. I love Goalscape and like to use it a lot and am going crazy, not to mention the fact that I am paying for it but cannot use it.

  1. Support Staff 1 Posted by Richard Parslow on 28 Aug, 2021 10:33 AM

    Richard Parslow's Avatar

    Hello Lucy

    Sorry you are still having trouble – this looks like a duplicate of your previous discussion here:

    Here is the text of our reply:

    I confirm that Goalscape Online is working fine in all our tests and we have not heard from anyone else having a problem, so we should be able to have you up and running again very soon.

    From your description, the most likely culprit is a firewall setting that is preventing the Goalscape Online app from connecting with the server. If you are using a corporate LAN, please ask your IT support to check the firewall settings for Allowed/Disabled apps and ensure Goalscape Online is Allowed. Otherwise, if you are using a personal firewall, the quickest way to check is to turn off the firewall, then try using the Goalscape Online app: if it works, you can turn on the firewall again, then find and change the relevant setting.

    If you are not using a firewall, or if turning it off makes no difference, please post again with the following details:

    • Version of the Goalscape Online app installed (from Goalscape Online > About).

    • A screenshot of the whole application window – in Windows you can use the Snipping Tool, then paste the image into Paint, save the image file and attach it to your email Reply (or post it here using the 'Choose file' button below the Reply field).

    • Whether you installed 'for Everyone' or 'Only for me'. If you cannot remember which installation option you chose, or if you may have used different options on different installations, please let us know that as well.

    Please follow the steps described; and if the issue is not with your firewall, please send us the relevant details – we will send you the instructions to clear your registry for a full 'clean' reinstall.

    All the best


  2. 2 Posted by lucy on 08 Oct, 2021 12:35 PM

    lucy's Avatar

    Many thanks Richard. I am still going crazy as I cannot get the app to work on my Microsoft Surface Pro. It is a free standing lap top as I am a freelance Consultant and I am not part of a bigger organisation (there is no network). To date I have:
    1. notified you of the problem as above 2 x.
    2. turned off the firewall and tried to install etc. multiple times
    3. Ticked the various option boxes (for everyone and only for me) when I am installing. multiple times
    4. Rung a generic help desk (that I subscribe to) and taken it to a physical help desk. No one has been able to solve the problem and they think there is a problem with the windows app.

    Please also note I have been able to successfully install the desk top app (but I cannot use this as I do not have the desk top licence) AND I have successfully installed the on-line version on a friend's imac (and accessed my account/goalscapes). So I am confident that I am not doing anything basic wrong.

    In terms of the version of online app, I am using the link on your website that says goalscape for online windows. So it is whatever version that you are currently offering.

    Please can you help? I have been trying for ages to sort this and I really need the functionality and access to my goalscapes. I have limited ability via the mobile app, but this is no good for planning etc. If you cannot resolve it quickly, can you at the minimum give me access to the desk top licence until this problem is resolved.

    Many thanks


  3. Support Staff 3 Posted by Richard Parslow on 08 Oct, 2021 04:54 PM

    Richard Parslow's Avatar

    Hello Lucy

    Sorry you are still having trouble.

    The fact that you successfully installed the Goalscape Desktop app is very encouraging! It indicates that there is no problem with our installer or your environment: the most likely cause of the installation issue is interference from a previous installation of Online.

    We will send you instructions to remove any remaining Goalscape Online files and clear your registry for a full 'clean' reinstall. Because this requires searching specific locations (depending on OS and installation option used), to help us to help you as fast and as simply as possible, please could you provide the following details:

    • Version of Windows you are running

    • Version of the Goalscape Online app installed (in Goalscape Online > About – if the application menu is accessible).

    • A screenshot of the whole application window – in Windows 10 you can use the Snipping Tool, then paste the image into Paint, save the image file and attach it to your email Reply (or post it here using the 'Choose file' button below the Reply field).

    I understand you may have previously installed the Goalscape app 'for Everyone' and 'Only for me'; we will ensure that the instructions cover the file locations for both options.

    All the best


  4. 4 Posted by lucy on 12 Oct, 2021 01:42 PM

    lucy's Avatar

    Hi Richard

    I replied directly to you email on Saturday, but have not heard back from you. So to answer your questions again:

    1. I am running Windows 10 Version 21H1. Installed on 22/3/21 OS Build 19043.1237
    2. Version of goalscape - not possible to say because the application menu is inaccessible
    3. I attach an image of what happens after I have installed the software when I launch it. I get a goalscape icon in the bar at the bottom of my desk top. When I click on it opens up into a small blank window while I press my cursor on it, but it does not open up into a full sized window and there is no content in it.

    I look forward to receiving your instructions!

    Best wishes


  5. Support Staff 5 Posted by Richard Parslow on 12 Oct, 2021 02:16 PM

    Richard Parslow's Avatar

    Hi Lucy

    Thanks very much for sending that information – especially the screenshot.

    It seems that at the very least the shortcut in the Taskbar is broken: it may be pointing to the installed 'for Everyone' location when the latest installation was 'Only for me'. It could also be that the Registry information from a previous installation is affecting this one.

    So to ensure a full 'clean' reinstallation please follow the steps below. Please note that this requires changing some System files, so you not only need Admin rights, you also need to be able to view Hidden Files and Folders (the instructions to 'Show Hidden Files and Folders' are at the top of our Resetting Registry page).

    1. Uninstall the old Goalscape Online app using 'Add or Remove Programs' (or click its icon in the Start menu and select Uninstall).

    2. If the Goalscape Online shortcut is still in your Taskbar, Remove it (once you have the app running again, you can Pin its shortcut to the Taskbar).

    3. Check for any residual Goalscape Online directories (these may affect how the new app is accessed) – depending how you did your previous installation(s), these could be in more than one place, so please check both these locations:

      1. If you installed the app 'for Everyone', delete the 'Goalscape Software' (or 'Goalscape Online') folder in C:/Program Files
      2. If you installed the app 'Only for me', delete the 'Goalscape Software' (or 'Goalscape Online') folder in C:/users/[user_ID]/AppData/Local/Programs

        Note: if you cannot see the 'AppData' folder, that means it is Hidden – the instructions to 'Show Hidden Files and Folders' are at the top of our Resetting Registry page.

    4. Clear your Registry: delete the folder in C:/users/[user_ID]/AppData/Roaming (again, you need to be able to View Hidden Files and Folders).

    5. Depending on your installation options (and any LAN settings), your Windows environment may have stored the Registry information under a different userID, so please also check the AppData/Roaming directory under other user_IDs like 'Default', 'All users' or 'Guest': if you find a folder, delete it.

      Sorry if this seems arduous: unfortunately Windows does not allow you simply to Search for the string '' in Explorer.

    6. Clear your browser cache.

    7. Download the latest version of the app from here:, run the installer and follow the onscreen instructions (if possible, select the 'for Everybody' option).

    Please let us know if this works for you; or if you still have any trouble please send details (and if it is a different issue, please include another screenshot).

    Thanks for your patience and persistence here.



Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac