Goalscape Desktop not opening anymore...

Meindert Schaap's Avatar

Meindert Schaap

14 Nov, 2021 04:11 PM

Hi Team,

My Goalscape Desktop is not opening anymore... I have tried various ways to solve it, but nothing worked. Uninstalled and reinstalled, also didn't work. The Goalscape button shows up in my toolbar at the bottom of my screen, but when I click on it nothing happens. When I hover over it, it also shows a completely empty screen preview.
I also tried to open my gsp files, but they don't open and Windows asks me to select a software program to open it -- with a drop-down that doesn't show Goalscape in there.

Please help -- I love Goalscape and use it almost every day!
Hope you can help. Thanks loads in advance,

Meindert

  1. 1 Posted by Meindert Schaap on 14 Nov, 2021 04:23 PM

    Meindert Schaap's Avatar

    I also cleared my Google Chrome Cache... did not help either...
    The Goalscape Desktop app used to work flawlessly... for the past months...

    Please help...! --- see also the attached Word document containing two screenshots:
    * one of the EMPTY Goalscape Screen preview, from Toolbar; * one of the "What do you want to open your GSP file with...?"

    I hope you can solve this ASAP. Thanks!

    Meindert

  2. Support Staff 2 Posted by Richard Parslow on 14 Nov, 2021 05:42 PM

    Richard Parslow's Avatar

    Hello Meindert

    Sorry you have had trouble; thanks for those screenshots.

    From your description and the screenshot, it may just be a broken shortcut in your Taskbar. Can you see the 'Goalscape Desktop' app folder/icon in your Start menu (the one that appears when you click the Windows button at bottom left)? If you can start it from there (or from your Programs folder in the file handler), pin the new shortcut that appears when the app starts and remove the old (empty/broken) one.

    If Goalscape Desktop does not appear in the Start menu or Programs folder, or if it is there but will not open when you click it, the installation must be either corrupted or inaccessible. That means you need to clear your Registry to ensure a full 'clean' installation: detailed instructions for doing this are on our Knowledge Base here, under Resetting the Registry.

    Note: the issue may be due to your having selected different options ('for Everyone' or 'Only for me') during your installations. So if resetting your Registry does not work for you (or if you cannot find the registry under your Windows User_ID account), please post again to confirm whether you selected 'for Everyone' or 'Only for me' when you installed Goalscape Desktop.

    All the best

    Richard

  3. 3 Posted by Meindert Schaap on 14 Nov, 2021 07:00 PM

    Meindert Schaap's Avatar

    Hi Richard,

    Thanks for the quick response.... still not working. The odd thing is that Goalscape had been open in my bottom toolbar for several weeks (I keep it open, as I use it frequently). Then suddenly, after a few days of non-use, I clicked the icon and NOTHING happened... So, it was the same Goalscape that I had working flawlessly before (it wasn't a new installation).

    RE your suggestions:
    It's not a broken shortcut. Clicking any saved gsp file also does not find Goalscape anymore (as you saw in the second screenshot). Goalscape.exe is there -- and shows a spinning wheel for a few seconds, as though it is opening, then shows the Goalscape icon in the task bar... but it is empty/void... and clicking it does nothing.

    So, it looks like the installation is inaccessible... which is strange because I had not closed Goalscape at all, and it was working perfectly before... Now clicking the same icon in the task bar suddenly broke...

    I uninstalled Goalscape, and then ran a Regedit and searched for any "Goalscape" reference, and deleted them all. Then reinstalled using the msi file. Same problem persists. Goalscape is there, and "opens" but is completely void... / inaccessible... still.

    I have tried the above with both installation options: for everyone, and only for me. Both times it gave the same VOID problem, and still gsp files cannot find Goalscape to open in.

    Help! I really need my Goalscape....!
    Hope it can be fixed soon --- meanwhile, could you give me temporary access to the online version...? I struggle without my Goalscape...

    Thanks again!

    Meindert

  4. 4 Posted by Meindert Schaap on 14 Nov, 2021 07:15 PM

    Meindert Schaap's Avatar

    NOTE that there was NO "com.goalscape.app.GoalscapeDesktop" reference AT ALL in the Registry... I ran a Regedit Search, and that string was not found...

  5. Support Staff 5 Posted by Richard Parslow on 14 Nov, 2021 08:03 PM

    Richard Parslow's Avatar

    Hello Meindert

    Yes, in that case it is definitely a Registry issue. The Registry must exist on that machine somewhere, because you previously activated the software there; and since you could not find the com.goalscape.app.GoalscapeDesktop folder to delete it, the Registry has still not been cleared.

    Please note that you may not find these system files using Regedit: you need to go into the folder: C:/Users/[User_ID]/AppData/Roaming, then scroll down to the com.goalscape.app.GoalscapeDesktop folder and delete it.

    1. If you cannot see the AppData folder, it means it is Hidden, so you need to Unhide it using the instructions to View Hidden Files and Folders in Resetting the Registry.

    2. If you can see the AppData/Roaming folder and there is no com.goalscape.app.GoalscapeDesktop folder to delete, that means something strange happened when you installed it. So please check the AppData folder under any other user accounts you see under Users (eg 'Default', 'Public' or 'Guest').

    Once you have found and cleared the Registry, your next installation should work correctly. You may also wish to delete the shortcut in your Taskbar (a new one will appear when you start the app).

    If you manage to find and delete the Registry, and your new installation still fails, it is possible that the fact that you have previously used both install options ('for Everyone' or 'Only for me') may be an issue, since the Windows Uninstall process may miss some files. So to check for any such 'rogue' files, after you uninstall Goalscape Desktop, go to the following locations and delete any 'Goalscape Desktop' Program folders you find:

    1. 'For Everybody' installation file location:

      C:/Program Files/Goalscape Software

    2. 'Only for me' installation file location:

      C:/Users/[User_ID]/AppData/Local/Programs/Goalscape Software

      **NB as your Registry was not under your User_ID, if you found it under a different User_ID, please also check the AppData/Local/Programs folder under that User_ID for any rogue Goalscape Desktop Program files.

    Then clear the Registry and reinstall Goalscape Desktop (the Windows .msi file is here).

    All the best

    Richard
    PS Please always use 'for Everybody' during installation if possible, as that makes the Program files easier to locate.

  6. 6 Posted by Meindert Schaap on 15 Nov, 2021 11:32 AM

    Meindert Schaap's Avatar

    Hi Richard,

    Thanks again for all the help! Did all the steps you listed, and
    Hallelujah, it worked!! So happy to have my Goalscape working again!

    Still a mystery how it got corrupted (as I did not do anything -- I just
    left the software open in my TaskBar... and then from one day to the other,
    it stopped working...)... Hope it will not happen again!

    Cheers,

    Meindert

    --
    *Meindert Schaap (Clinical Child Psychologist) ----
    <https://www.linkedin.com/in/meindertschaap>*
    *Executive Director*
    +255 (0) 754-307-058

    *Rescuing Street Children. **Restoring Hope. **Transforming Lives.*

    www.amanikids.org

    --

  7. Support Staff 7 Posted by Richard Parslow on 15 Nov, 2021 02:46 PM

    Richard Parslow's Avatar

    Hello Meindert

    Splendid! Thanks for letting us know that you have Goalscape Desktop up and running again.

    As to the cause of the issue: if it worked after you found and deleted the Registry, then the Registry was definitely what was stopping Desktop from starting. Since you could not find the 'com.goalscape.app.GoalscapeDesktop' folder under AppData/Roaming in your Windows User account, it must have been under a different User_ID. So the Registry issue could have been due to some changes that happened in that other User account, or in the way that user account access works on your amanikids LAN.

    I confirm that when you are logged in to Windows under your own User_ID and select 'for Everyone' during installation, the Program itself is installed in C:/Program Files and the Registry is created (or updated) in C:/Users/[User_ID]/AppData/Roaming.

    Keep achieving great goals!

    Richard

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac