Copy & Paste from the clipboard online using Firefox

gregg's Avatar

gregg

16 Mar, 2022 08:08 PM

This is a Known Issue for goalscape (https://goalscape.tenderapp.com/kb/known-issues/goalscape-web-appli...) as of 03/16/2022:

Cannot Paste Goal in Firefox. Message: 'Access to clipboard denied - please update your browser Preferences' – yet there is no such Setting in Firefox. We have contacted Mozilla about this and are awaiting their response; we are also investigating a possible workaround.

In the meantime please use another browser: we recommend Google Chrome or Microsoft Edge – both work well under either Windows or macOS.

Yes I am getting this problem.

I just found this technical reference: https://developer.mozilla.org/en-US/docs/Web/API/Clipboard#clipboar...

It says for clipboard.read():

From version 90: this feature is behind the dom.events.asyncClipboard.read preferences (needs to be set to true). To change preferences in Firefox, visit about:config.

footnote Firefox only supports reading the clipboard in browser extensions, using the "clipboardRead" extension permission.

for clipboard.write():

From version 87: this feature is behind the dom.events.asyncClipboard.clipboardItem preferences (needs to be set to true). To change preferences in Firefox, visit about:config.

footnote Writing to the clipboard is available without permission in secure contexts and browser extensions, but only from user-initiated event callbacks. Browser extensions with the "clipboardWrite" permission can write to the clipboard at any time.

(I am on firefox v98.0 on 03/16/2022 and I see there's a new update).

Searching about:config I also found dom.events.testing.asyncClipboard.

After I set those 3 preferences to true in about:config, and reloaded my goalscape.app page, voila, I could paste goals in firefox.

For clarity/brevity, the 3 settings are:

dom.events.asyncClipboard.clipboardItem
dom.events.asyncClipboard.read
dom.events.testing.asyncClipboard

I'm trying to upload a picture too.

(Related post: "Copy & Paste online using Firefox" https://goalscape.tenderapp.com/discussions/issues/20721-copy-paste...)

  1. Support Staff 1 Posted by Richard Parslow on 16 Mar, 2022 09:48 PM

    Richard Parslow's Avatar

    Hi Gregg

    Ha! Thanks very much indeed for posting that fix – I'll update the KI right now.

    Cheers!

    Richard

  2. 2 Posted by gregg on 18 Mar, 2022 04:34 PM

    gregg's Avatar

    The Known Issues (https://goalscape.tenderapp.com/kb/known-issues/goalscape-web-appli...) don't say after changing the about:config clipboard settings, you then have to reload your goalscape.app page.

    I just tried these steps on a second computer, and I still needed to reload goalscape to get it to work. And it did work. Yay!

  3. Support Staff 3 Posted by Richard Parslow on 18 Mar, 2022 04:52 PM

    Richard Parslow's Avatar

    Yes: as soon as you posted the fix here I tried it on Windows and Mac and was overjoyed when it worked. As you suggested I have now added 'refresh the browser' to the Known Issues.

    Although we try to cover everything, we are also lucky to have customers who are even better-informed than we are in some areas. So thanks again!

Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac