Desktop Verson of GoalScape

Robert Vanderhoof's Avatar

Robert Vanderhoof

27 Sep, 2019 03:00 PM

Goalscape now only opens if I run it as an administrator. Can this be remedied?

Windows 10
Goalscape 2.9.8 [build 4242.1454]

  1. Support Staff 1 Posted by Richard Parslow on 27 Sep, 2019 08:43 PM

    Richard Parslow's Avatar

    Hello Robert

    Sorry you have had trouble.

    When you Activate a Goalscape Desktop installation, it creates a Registry entry on your hard drive. If you are logged in to an Administrator account when you do that Activation, the Registry for that user account will be updated.

    If you want to Activate your Desktop under a different UserID, you will need to login to your computer (or LAN) under that UserID, then start Desktop. If you see the Welcome screen, you can (re)Activate that installation, then the correct Registry will be updated.

    If you do not see the Welcome screen when you start Desktop, please post again with details of what you do see.

    All the best


  2. 2 Posted by robert on 28 Sep, 2019 12:51 PM

    robert's Avatar

    I don't believe one of us understands the problem. I operate under one
    account. I installed the software under that account. It used to work
    fine under that account until a few days ago when I tried to open it and
    nothing happened. On a whim I right-clicked on the Goalscape icon and
    chose "Run as Administrator" and it opened. In fact that is now the
    only way it will open. I don't want to activate Goalscape under a
    "different UserID." When the program opens, it opens normally showing
    the startup template. I want to be able to start Goalscape without
    having to run it as an administrator.

  3. Support Staff 3 Posted by Richard Parslow on 28 Sep, 2019 09:40 PM

    Richard Parslow's Avatar

    Hello Robert

    Sorry for the misunderstanding.

    We cannot reproduce this anomaly in any tests; and we have not heard from anyone else who has encountered it.

    The 'Run As Administrator' option you see when you right-click the Goalscape Desktop application icon is not a Goalscape Desktop facility; rather it seems to be an OS option.

    Did you install the latest Desktop updates a few days ago? If so, please try the 'uninstall and reinstall Goalscape Desktop and Adobe AIR' fix - full instructions are on our Known Issues page.

    If problems persist please post again with the following details:

    • Operating System and version (eg Windows 10)

    • Installed versions of Goalscape Desktop and Adobe AIR (you can see both if you mouseover the 'Goalscape' logo at top left of the Desktop screen

    All the best


  4. 4 Posted by robert on 09 Oct, 2019 02:53 PM

    robert's Avatar

    I tried uninstalling and reinstalling Adobe AIR and Goalscape, and I get
    the same behavior.

    Windows 10
    2.9.8 (build 4242.1454)

    It used to run fine, up until about a month ago.
    I would really like to get this fixed.


    Robert Vandrhoof, Ph.D.
    Silva Systems, LLC

  5. Support Staff 5 Posted by Richard Parslow on 09 Oct, 2019 04:04 PM

    Richard Parslow's Avatar

    Hello Robert

    Sorry you are still having trouble.

    We cannot reproduce this behavior and we have not heard from anyone else who is experiencing it. I confirm that the 'Run As Administrator' option is definitely not a Goalscape Desktop facility; rather it seems to be an OS option, so you may be able to adjust it in your Windows Settings.

    I searched the internet for 'Windows 10 run as administrator option': this article Always run a program in administrator mode in Windows 10 explains how to access the option. Since it appears to be turned on for Goalscape Desktop for you right now, you should be able to follow the instructions to turn it off.

    Please post again to let us know if this works for you.

    All the best


Discussions are closed to public comments.
If you need help with Goalscape please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac